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Welcome to Tensor Cad/Cam 

Tensor is an easy-in-use Cad/Cam system for Windows™ with a wide range of powerful 
2, 3 & 4 Axis programming capabilities. From lathe, to 2D profile milling, simple and 
advanced pocket milling operations, hole drilling and engraving to toolpath generation for 
imported  3D-files.  CNC-code  can  be  generated  for  numerous  controllers.  Tensor 
Cad/Cam was specially developed for users of CNC-machines. This means that not only in 
the metal-cutting industry Tensor is being used, but also in the woodworking and plastics 
industry, Tensor is a fine solution in CNC-programming.

Experience
Tensor was introduced in 1996 in the industry and has since then been very succesful on 
the  market.  We  work  closely  with  our  partners,  being  our  users  and  CNC-machine 
vendors. For years we have listened carefully and learn from their ideas and proposals in 
improving the quality of Tensor. This probably is the main reason users are so satisfied 
working with Tensor. Tensor is available in several languages, at today these are English, 
German, French and Dutch.

Draw and program
By  using  the  intelligent  developed  philosophy  of  drawing  with  Tensor,  the  user  will 
construct profiles in no time. By then selecting an NC-job, Tensor will take you through a 
dialog and let you machine the profile any way you desire. Not only for milling and lathe, 
but also for Wire-Edm lasercutting and waterjet TensorCadCam is the perfect tool. By 
using the Dxf -and Iges-translator you will be able to import these files and convert them 
directly into CNC-code.

Simulation 
All generated NC-programs for lathe and milling can be simulated and checked in the 
Tensor NC Simulator. Machiningtime will be presented. Programs not made with Tensor 
Cad/Cam can also be simulated making this a very strong part of the Tensor software. 
After  all,  Tensor  NC  Simulator  simulates  real  CNC-code  and  not  a  Tensor  related 
language as most of our competitors do.

Mechanical drawings
Tensor  is  equipped with several  simple but  very strong options to generate  detailed 
mechanical  drawings.  Tensor  is  therefore  a  very  suitable  option  making  schemes, 
technical manuals and instructionbooks.

Internet
Please  regularly  visit  our  website  www.tensorcadcam.com for  the  latest  news  and 
developments. You may also leave a note to be taken up in our mailinglist.

Use this manual!
This manual is the best place to take off with Tensor. Is was held as compact as possible 
to invite you to work through the entire manual. Don’t think you will comprehend the 
philosophy behind Tensor by just clicking the mouse on your screen. Therefore: start 
working through this manual, you will not regret this decision ! 
It will  learn you in a short period of time the basic notions and basic skills  that are 
necessary to be productive with Tensor. After this you should be able to work with Tensor 
without much effort. You will then by simply using Tensor, learn more and more about 
the powerful capabilities Tensor can offer you when programming. By following a one-
day-training may even accelerate this. For this contact your dealer.

In this manual we presume you are familiar in working with Windows™. This means you 
know how to use a mouse,  open menus and know how to select/activate options in 
dialogboxes.  You  should  also  be  able  to  open  and  close  documents(drawings). 
Information about Windows™ you will find in manual provided by Microsoft or on-line 
Help information. If you need to do this, read chapter 1 and 2 in the Window manual 
where the basic skills are being explained.

We wish you good luck and a lot of fun using Tensor.
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System requirements

What you need to use Tensor 4.0:

The minimum requirements are:

- Microsoft Windows™ 98 or ME 
- Microsoft Windows NT/2000/XP 
- PC with minimum of 300 Mhz processor or higher
  Intel Pentium™/Celeron-family, AMD™ K6/Athlon/Duron-family or compatible 
  processor recommended
- Super VGA-screen and screen adaptor with minimum resolution of 800x600 or higher
- 32MB Ram memory (64 MB or higher recommended for a better performance)
- 1 Gigabyte free disk space
- CD Rom or DVD
- Keyboard and Mouse compatible with Windows™ 
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Installation of Tensor
Follow procedure as is described here to install Tensor on your PC:

Installation-CD
If  you  want  to  install  the  software  on  a  PC  where  previously  Tensor  has  not  been 
installed, you may put the Tensor installation-CD into your computer. If not first remove 
Tensor from your PC by using the Start-button in the lowerleft corner of your screen and 
then  prodede  with  Congifuration->Software.  Then  select  Tensor  from  the  list  and 
Uninstall(Remove) Tensor. During installation you will be asked to select a installation 
directory.  If  you don’t  have  a  particular  reason  to  install  in  a  different  directory  as 
presented, best leave it lake that.
 
Shortcuts 
During installation a shortcut for Tensor will be made on your desktop:  

For Cad/Cam users:
Make your own shortcuts on your desktop for the Lathe- and Millsimulator. The program 
name for  the mill-simulator is  to be found in directory ncsimulatormill  in the Tensor 
directory. It’s called Tensor_NC_Simulator_Mill.exe. If you are also planning to program 
for lathe you can do the same. The name is Tensor_NC_Simulator_Turn.exe to be found 
in directory ncsimulatorturn also to be found in the Tensor directory.

The dongle
Insert  the dongle  in  a  USB-slot.  Probably Windows will  ask you if  the driver should 
automatically be installed. If not, install this using setupdrv.exe. This file you may find in 
the Tensor directory. To check if this procedure is correctly being executed doubleclick on 
DDlook.exe. (to be found in the Tensor directory). This program will try to detect dongles 
inserted in USB-slots. If a dongle is recognized it means Tensor will also recognize this. 

Startup procedure
The first time you start, Tensor may ask you to select the right license from a list. This is 
presented with a number. On your USB-dongle you can see a sticker with a number. 
Select the right number from the list. If you are not sure which number the dongle has 
you can use DDlook.exe to check the number. If you by accident activate the wrong 
license Tensor will not start. To solve this you do the following: in the Tensor directory 
you may find a file: register.zip. If you unzip this file you will find one or more .reg files 
preceded by numbers corresponding with you dongles. By double clicking on the .reg file 
with the same number as the dongle inserted in the USB-slot, you will activate the right 
license. Then retry to start Tensor.

Files referred to in the manual
In  the  Tensor  directory  you  will  find  directory  documents.  By  doubleclicking  on  file 
OnyourwaywithTensor zip.exe  a list of Tensordrawings and video files will be unzipped 
into this directory. In this manual you will see that frequently is being referred to these 
drawings and videos. 
 
To make CNC-programs with Tensor as fast as possible using the correct method, it is 
important that you work through this manual. You might prefer to make immediately 
drawings and programs, but please take the effort to understand the principle of Tensor 
well, you won’t regret it. This principle is : “Order and direction of elements”
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Starting with Tensor

Draw
This manual contains several chapters. First we will take you through how to draw 
geometry in Drawing with Tensor. After you worked through this part you van proceed by 
trying to make the 15 drawings to be found in chapter Exercises. For each exercise you 
will find a corresponding .avi file in the documents directory, which will show you the 
fastest and best way to make this drawing.

NC-programming for milling
If you want to generate NC-programs for milling- an drilling jobs you can work through 
chapter NC-programming for milling. Here we will explain step-by-step how to generate 
an NC-program for a profile and how to simulate the program in the Tensor NC 
Simulator. After this, other features for several NC-jobs will be explained. 

As Tensor works in  dialog with the user and therefore is quit easy, we will do this briefly. 
The dialog will avoid the user making errors. Also in this part references are made to files 
in the documents directory. Take the effort to take a close look at them.
For 3D-milling jobs, examples are worked out in 3D milling in Tensor. It’s however 
recommended first to concentrate on 2D-programming, before you start with this part!

NC-programming for lathe
Here you will learn how to generate code for lathe. We will demonstrate to machine a 
part using Roughing-, finishing- and a drillcycle. After this, the other features available 
will be explained in short. You will simulate the NC-program in the Tensor NC Simulator 
for lathe-programs. And of course you will find the accompanied .avi and .ccd files.

The .ccd en .avi files
By unzipping file onyourwaywith zip.exe (found in the documents directory) the .avi 
and .ccd files mentioned in this manual will be unzipped are to be found in the 
documents directory. As you are making the exercises you can watch the videos in 
Windows™ Media-player. You can use the Pause and Forward and Rewind-buttons for an 
optimal use.

And finally:

Remember the principle: “DIRECTION AND ORDER” . This is what Tensor is all about!

We wish you a lot fun working with Tensor Cad/Cam.
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Drawing with Tensor
Open and close a drawing
To create a new drawing move to menu File->New. Then select Type Drawing, Based on 
normal. When opening a drawing you can move to File->Open and make your selection 
from .ccd files. Be sure that at the bottom of the dialogbox Filetypes says Drawing files 
.ccd. With File->Close you can close and if desired so, save a drawing. 

Object-Action 
Tensor is based on the Object-Acton principle. This means: before Tensor executes an 
Action, the elements which the action is appled for, need to be selected. For example: to 
draw a parallel line, the original line first needs to be selected before option Line-> 
Parallel is used. We will now take you through a number of methods to select elements.

Elementtypes
Tensor contains a number of basic elementtypes. Except lines and arcs these are the 
other basic elements in Tensor: point, text, dimension, face and objects. Besides the 
geometrical data they contain some more attributes. For example a color and a 
layername. But we will come back to this later on.

Select elements

Exercise: Watch ten0.avi
In this recording a number of elements are being selected clicking the leftmousebutton.
By “clicking” close to an element and release the button an element will be selected. It 
turns red and will have an arrow in the middle for a line and arc. To undo the selection 
you can click the leftmousebutton in the drawing-window not close to an element (empty 
space).
 
Exercise: Open drawing ten0.ccd.
We will now do the same as the recording:

 pic.1

Selecting more elements
If one or more elements are already selected and you want to select more do the 
following: press the CTRL-button and keep it down as you select more elements using 
the leftmousebutton. All previous selected elements remain selected. If you are through 
selecting, release the CTRL-button. If you don’t use the CTRL-button all selected 
elements will be deselected and only the last clicked element will remain selected. The 
numbers in pic.1  represent the order of selecting in this recording. The upper left line is 
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the first element in the selection-order, the linear dimension below is the last. Soon you 
will see why selection-order is so important.

Conclusion: To select extra elements you have to press the CTRL-button. If you click the 
left-mousebutton not close to an element, all selected elements will be deselected. This 
therefore is the easiest way to deselect elements.

Remark: As you are just starting with Tensor it may occur that you by accident deselect 
all the elements without noticing this when clicking the the leftmousebutton not close to 
an element

Direction
The arcs and lines selected in the first exercise contain an arrow in the middle. This 
indicates the direction of these elements. This also implies that arcs and lines have a 
start- and endpoint. 

startpoint

endpoint
startpoint

endpoint

 pic.2

In de selection in pic.2 the line and arc were selected on the side of the where you can 
see the cursor. The direction would have been reversed if they were selected on the 
other side. Elements such as text, dimensions and point however don’t have a direction.

Remark: The direction and order of elements will eventually also determine how the NC-
code will be generated. 

Chains
A number of selected elements (lines and/or arcs) attached to one another we call a 
chain. A chain can also contain just one element, one line or one arc. 

 pic.3

The chain in pic.3 you may find in ten0.ccd. By clicking the leftmousebutton on the 
indicated position and at same time pressing the SHIFT-button you will not only select 
the line but also the elements “attached” to this line.

  
Exercise:  Try to select this chain in drawing ten0.ccd.
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 pic.4

The selection-order of elements is in accordance with the numbers in pic.4. This means 
that the line on which is being clicked, is the last element in the selection-order. You 
could say this is logical as the arrow of line 1 is pointing into direction of line 2 and line 2 
into 3 , etc. 

This also implies that if we had selected line 1 with the SHIFT-button on the top, the 
direction and selection-order would have been opposite to this situation. (pic.5)

end

7

1

2
3

4

5

6

SHIFT

start

 pic.5 

end

1

SHIFT

start

 pic.6

The startpoint of the chain in pic.5 is the startpoint of element 1 and the endpoint of the 
chain is the endpoint of line 7.

If you click on the bottom of line 1 using the SHIFT-button, only line 1 will be selected as 
no elements are attached to its startpoint. (pic.6)

Tensor will keep on selecting when using the SHIFT-button, until there are no more 
elements attached to the last found element or it will “bump into” a already selected 
element. This occurs when selecting a closed chain. 

Exercise: in drawing ten0.ccd select the closed chain on the upper right side with the 
leftmousebutton and pressing the SHIFT-button. See pic.7
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2

 pic.7

We will do one more exercise selecting a chain. We want to select the chain also found in 
ten0.ccd. (pic.8) 

1

2 3

4

5

 pic.8

If in this case we would click at the end of line 5 using the SHIFT –button, there is a 
chance that Tensor will continue in the wrong direction from the crossroad on, because 
there are 2 options to continue from that point and that the result could be like in pic.9:

1

2 3

4
SHIFT

 pic.9

To be sure to get the wanted result you can start selecting the first part of the chain by 
clicking on line 3 using the SHIFT-button. pic.10:

1

2

3

SHIFT
 pic.10

To prevent selection going wrong, you can select line 4 by using the CTRL-button. pic.11
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1

2

3 4

CTRL
 pic.11

To select the remaining element(s) you can click on the end of line 5 using the SHIFT-
button. pic.12: 

1

2

3 4
5

SHIFT

 pic.12
This also means that it ‘s also possible to select a part of a chain: 

1

4

 pic.13

First select line 1 with the leftmousebutton. Then click at the end of line 4 using the 
SHIFT-button. Selecting will stop because we “bump into”  a selected element. pic.13

Exercise: Watch ten01.avi . 
Here you can take a look at actions described above.

Selecting using a window-box
The advantage of selecting with a mouseclick or chain(SHIFT) is that the user can 
determine the direction and order of the elements. But suppose you like to select 
elements in order to delete them, the order and direction will not be relevant. The fastest 
way to select in this case would be to move the cursor to the upperleftcorner in your 
screen and while pressing the leftmousebutton, drag the cursor to the lowerright corner 
to indicate a box. (be sure that you do not start dragging close to an element because it 
will immediately be selected). Elements need be totally inside the box. 

If you desire to select the elements which do not entirely lie inside the box, you can 
press the SHIFT-button while you are dragging the box.

Deselecting
Elements which are selected can ofcourse be deselected.  The fastest way is by clicking 
the left-mousebutton not close to an element.

The other ways are exactly the same as selecting elements. For example, you can 
deselect a chain by clicking with leftmousebutton at the end of a chain and pressing the 
SHIFT-button. Or you can drag a box around selected elements. Another option is by 
using the function Select . This is to be found in the menu Edit. Here you can for example 
make a selection based on Entity Type  or color , layername etc. or a combination of 
criteria. Try this out by defining your own criteria

So far the explanation of selecting elements. Remember well:
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Direction and Order of elements are very important in Tensor.

Selecting and deselecting is being done in the same manner

If by any chance problems occur selecting elements when working in Tensor, do not 
hesitate to read this part again.

Execute an action
As said before, an element needs to be selected before an action takes place on that 
element. An action for example would be to draw a line under a given angle at the end of 
an element.

Exercise: Open drawing ten01.ccd

 pic.14

Select the three chains as shown in pic.14

Move to menu Draw->Line->Angle or click on button   .
Enter the following values and click OK:

 pic.15

The result will be as shown in pic.16. On all three chains the action has been executed. 
Three new lines are placed at the end(!) of the selected chains. This is an essential point 
in Tensor. 

Conclusion: An action is always being executed on selected elements( and/or chains)

 pic.16

Tip: When drawing in 2D always leave the value Angle with Z-axis at 90 degrees.

1
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Deselect all elements by clicking with the left-mousebutton not close to elements
We will now fillet the chain in the upper corner. Select the chain in the same direction as 
we just did before. (The chain now contains 3 elements)

Move to Draw-Arc-Fillet (quickkey F)or click on button  and enter the following values 
and then click OK :

 pic.17       pic.18

The result will be that the fillet will appear between the last 2 elements in the selection 
( as in pic.18)  If you would have clicked option All, both corners would have been filleted 
with radius value 8. To UNDO the action(filleting) move to menu Edit->Undo
You will see the chain appear without fillet. You can also use this to undo the action:

 

Now fillet again and click on the All button with the following result in pic.19:

1
2

3

5
4

 pic.19

When filleting Tensor will automatically define a new order of elements in accordance 
with the numbers in pic.19 above. 

Conclusion: Don’t ever hesitate or be afraid to try out functions in Tensor. You can 
always Undo your action. The Undo-function is applied to all geometric changes being 
made in Tensor. 
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pic.20

In pic.20 two lines are selected which can be connected using the function Draw-> Line-
>Connect (quickkey J). The order of selection will be like the numbers shown. 

Conclusion: Tensor takes care for a logical order after geometric changes have been 
made in selected elements.

Drawing a profile

We will draw the profile in pic.21.
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55

30

R30

R15

 pic.21

If we take a closer look at the drawing it seems logical to define the startpoint of the 
profile on the lowerleft corner, as dimensioning starts from there. In the center of 
the drawing-window you can see blue axes:

 pic.22

This is the absolute zeropoint of the drawing window. Direction of the X-axis is indicated 
by the line with one arrow, the Y-axis by the line with two arrows. For the Z-axis there is 
a line with 3 arrows, but as we are looking at the XY-plane, this is not visible. (Don’t 
confuse these axes with those on the upperright corner. These represent the view-angle )
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Exercise:  Watch ten02.avi 
To create this shape (pic.21) it is good to have a zeropoint. This because the function 
Draw-> Line->Sketch (quickkey L)is being used to draw horizontal and vertical lines with 
coordinates. By dragging the cursor with the left-mousebutton from left to right over the 
screen you can define a horizontal line by entering a value on which Y-value the  lines
 should be. This Y-value is of course related to the zeropoint. In the same manner you 
can draw vertical lines by dragging the cursor from the bottom-to-top direction (or vice-
versa) and entering an X-value. The Y-values you the enter to a vertical line represent 
the Y-start coordinate and Y-end coordinate of the line.

Trim 

In this example you will have noticed the function  Change->Trim+extend->Chain 
(quickkey T) is also being used. This function is used very often while working with 
Tensor. You can extend or trim elements to create a chain. The order of selection will 
determine how they will be trimmed.

result

1

2

3

4

1

2

3

4

result

pic.23 

In pic.23 we can see that a different order or direction of elements will have a different 
result. In this case only lines are trimmed, but of course it also applies to arcs (pic.24): 

1

2

3

4

result

 pic.24

Exercise: Try to make the profile in pic.21. Take a look at Exercise 1 in chapter 
Exercises to see which functions you will need in this example

Zoom-in and zoom-extend
In ten02.avi the view is frequently adjusted. Three buttons are mainly used for this 
(pic.24): 

         pic.25

When clicking on the left button the scaleview is reduced half. The middle button will 
place all the geometry in a maximum screen (quickkey Z). The right button allows you to 
enlarge a part of the drawing by dragging with the left-mousebutton a box around the 
desired part. 
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Closed chain

In ten02.avi the Trim function is several times being used. However during the last 
action 

the button Closed Chain was activated. This option will ensure that while trimming not 
only the elements will be trimmed in the order they were selected, but also that the last 
element will be trimmed to the first element with a closed chain as result. The Closed 
Chain option is also often used by other functions in Tensor. For example, if you want to 
fillet all corners of a closed chain you also need a fillet between your first and last 
element. So remember: when you want to close a chain you can use the Closed Chain 
button. 

Exercise: Now try to draw exercise2 from chapter Exercises (Also watch 
exer2.avi)

Cut and Paste

R1
0

R83

R1
6,2
5

R
13
2,
5

50

66,25

pic.26

The profile in pic.26 is a symmetric shape. This means we should try to draw one quarter 
and then mirror this in X- and then in Y-axis.

Exercise: Watch ten03.avi.  

In this example Tensor will make use of the clipboard of Windows. If you are not familiar 
with this Clipboard: you can copy selected elements/objects (quickkey CTRL C)within 
Windows to the Clipboard and then paste these objects back on a different location within 
Windows.
 
Thus also in Tensor: a quarter of the shape will be copied to the clipboard. When you 
want to paste this quarter, move to menu  Edit->Paste (quickkey CTRL V).The following 
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dialogbox will appear (pic.27):

 pic.27

All the possible options to paste geometry back into the drawing are available: Move, 
Rotate, Scale and the number of Copies. If let’s say you want two copies at a 
distance of each 50 mm in X, and 60 mm in Y, enter the following values (pic.28):

 pic.28

You will notice the total distance of the two copies is entered X:100 (2*50) and Y:120
(2*60). As we entered 2 copies, Tensor will automatically divide the translation over 
the 2 copies. This of course also applies for Rotation. If you want 11 copies divided over 
360 degrees, you can simply enter 360 at Rotate-Z and enter 11 as number of Copies.
(In 2D you will always use the Z-axis as rotation-axis. This Z-axis after all, points at you 
from the screen). By deactivating the 3D button in the lower rightcorner Z-displacement 
and Rotation in X- and Y-axis are switched off.  

Conclusion : The user should mind that the axes are on the right place when rotating. 
This because that will be centerpoint of rotation.

Exercise: Now draw the profile in pic.26. Take a look at Exercise 3 in chapter 
Exercises 

to see which functions you will need in this example and you can watch 
exer3.avi

Verify

1



 pic.29

In option Special->Verify (quickkey W)you will find all information about geometry 
present in your drawing (pic.29). This can be useful if you for example would like to
 check if a selected chain is closed. If the chain is closed the value of Total Area of chains 
there will be different than 0. Number of entities stands for the number of selected 
elements. If no elements are selected the value represents the total number of elements 
present in the drawing.

Conclusion: With Special->Verify you will be able check geometry of (selected) 
elements. 

If nothing is selected the values apply to the entire drawing.

Calculator
If you for example would like to enter a value for Z-rotation of 135/4.67 you may enter
 this as 135/4.67. Tensor will recognize this and calculate the proper value. You can also 
use expression as multiplying(13*7), subtracting(13-4.15), adding(45+12.7) and even 
sinus(sin 45), acosinus( acos(1) ) etc. 

Move Axes
Suppose: you want to rotate a number of elements but the point of rotation is not the 
zeropoint of the coordinate-system. As we can only rotate over (0,0) we will have to 
translate the axes to this point. 
Exercise: Watch ten04.avi . 

You will see in the menu Axes there are several options to move and rotate the axes. The 
first option is Snap to (quickkey P). Snap points are positions whereto you can move the 
axes. In menu Special->Options in tab-page snap points you may see what kind of snap 
points are available and if they are activated or deactivated (pic.30): 
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 pic.30

Exercise:Watch ten05.avi 

In ten05.avi we run through all options in the Axis-menu. Especially Align X (quickkey 
X) might be very useful to your needs. To draw the rectangle 5x5 inside the big 
rectangle, 
requires a lot of effort if the axes are in their original position. This option can save 
you some time calculating the displacement and rotation. 
Exercise: Now draw the profile in Exercise 4. (Watch if necessary video 

exer4.avi)

Exercise:Watch ten06.avi 

Another often used option is the snap point. In ten06.avi a copy of a chain is made in
such manner that the lower left point is in coordance with the upper right point. 
Without knowing what the distance in X and Y between points is, we can make a copy by 
simply moving the axes and enter values for translation (0,0). The experienced 
Tensor-user very(!) often uses this method of moving the axes from one snap point to 
another. With option  Axis-> Reset (quickkey R) you can reset your axes back to the 
original position.

Attributes 
Each element has its Attributes (quickkey A). They are more or less properties. 
To start: each element has a layername . You might for example give a number of 
elements which are related in some way, the same layername (for example a chain). 
The default value of the layername is 0. The default layername is visible in the 
box in the upper right corner of the screen (just as the default color is) pic31: 

  pic.31

Also in this case, you first need to select element(s) before you can adjust its attributes. 
Move to menu Edit->Attributes to open the Attributes dialogbox. This box contains a 
number of tab-pages, one for each elementtype. pic.32

 pic.32

In General the layername can be adjusted and you can temporary make an element 
Invisible(Blank). (In menu Change->Unblank they can be made visible again). 
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In tab-page Contour attributes of lines and arcs can be altered. The names of the other 
tab-pages speak for themselves. Especially tab-page Dimension is extended in options.
In menu Draw->Dimensions->Setup more settings for dimensions can be made

Attention: If no elements are selected and the Attributes are being changed in the 
dialogbox, they will automatically turn into the default attributes.

Change

Open drawing ten0.ccd.
In the Change-menu you will find item Modify. If you have selected one or more 
elements the geometric data of the last selected element will be shown, which can then 
also be adjusted. For example the length of a line can be changed at the lower end of the 
dialogbox. Because the button in End,Angles is activated only the endcoordinates will be 
adjusted. (pic.33) 

      
pic.33

For an arc you might want to change the centerpoint or the radius and total angle in the 
Modify dialogbox.

 Modify Mode
In the Change menu you will find the Modify mode option. This option is also present in 
the toolbar. By clicking on the button it will be activated. The cursor will change into a 
black arrow. If you now double-click with the left-mousebutton on an element in your 
drawing, Tensor will present you it’s geometric data. 

By activating this arrow you can also move an element or lengthen/trim a line or arc
If you for example move the cursor to the end of a line and keep the left-mousebutton 
pressed, you can drag the cursor and change the length of the element. If you drag the 
cursor from the middle of an element, you will change its position. If you while dragging 
also press the CTRL-button, you will be able to adjust the element as it was an elastic. If 

you by accident made the wrong adjustment you can Undo this by clicking on: 

If geometry needs to be changed accurately you might not want to use this option as it’s
not very accurate dragging the mouse. By clicking on the Modify mode button it is been 
deactivated.

Tip:
When the Modify mode is activated you will be able to drag a copy into your drawing 
by clicking the left-mousebutton close to an element and pressing the CTRL-button. This 
ofcourse is not accurate but sometimes might  come in handy “ to make a quick copy” . 

Exercise:  Make exercises Exer5 and Exer6 in chapter Exercises. Watch if 
needed video exer5.avi and exer6.avi.

Dimensions
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As Tensor is also a CAD-system dimensioning-functions must be available. Actually, they 
are very easy in use. 

In het Draw-menu you will find submenu Dimensions. In this menu there are several 
options of dimensioning.  (pic.34) 

 pic.34

Open drawing ten0.ccd. (if not already opened)

Exercise:Watch ten07.avi 
In this video all options in the menu are being showed. The  Single dimension is the most 
common used. If one or more elements are selected you can full automatically dimension 
the elements by just moving to Draw->Dimension->Single (quickkey E). This of course 
is a very fast  manner to dimension a drawing but not always what you would like to do. 
If no elements are selected you can activate the option and Tensor will in this case ask 
you to indicate two snappoints where after Tensor will place a dimension. 
You will notice that Tensor can both generate horizontal as well as vertical dimensions. 
This depends on the X- or Y-distance between the two indicated points.

In ten07.avi you can see that if the Modify mode button is activated you can place the 
cursor in the center of the dimension(at the little cross) and then drag this through a 
circle which will appear. You can  then change the orientation of the dimension as 
desired. The Horizontal and Vertical options in this menu speak for themselves.

As described earlier, you can change Attributes of dimensions in the Attributes dialog box 
in tab-page Dimension. The quickkey for Attributes is A. Here you will find a wide variety 
of attributes you can define.

Draw Menu
Inmenu Draw menu you will practically find all functions available to define geometry like 
Line angle, tangent lines to arcs, all kind of options to define points etc. In the sub-menu 
Other curves there are some more powerful options to make geometry also to be used to 
generate CAM geometry. For example feature Pocketing and Rectangle are available. So 
you don’t have to draw 4 lines to have a rectangle on your screen.

Exercise:  Make exercises Exer9 and Exer10 in chapter Exercises. Watch if 
needed video exer9.avi and exer10.avi.

Exercises
In chapter exercises there are 15 exercises. You can watch the accompanied .avi files 
These can be played with Windows Media Player™. The videos will take you step-by-step 
through drawing the profiles of the exercises. In the Windows Media Player™ it’s 
possible to Pause during playing go Forward and Backwards. This will help you to study 
the .avi files even better. Practically all functions available in Tensor are being used in 
these exercises and it’s therefore very(!) useful to try to make these drawing yourself  .
If you however are anxious to make your first NC-program in Tensor you can proceed to 
the next chapter.
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NC-programming for milling
In the preceding chapter have we learned how we to define geometry in the drawing 
window. In this chapter we will show you based on an example how to generate an NC-
program for milling. You will notice that through dialog the NC-program is being built up 
for a specific NC-job. 

For users, not working with a Fanuc-controller but for example are using a Heidenhain 
controller, some dialogboxes will not look familiar. But work through this chapter using 
the Fanuc postprocessor and then repeat this for the controller you prefer. You will notice 
that the dialogboxes will differ per controller on four basic points: 
1.startlines of a progam 
2. Endlines 
3. Loading a tool 
4. Cycles (p.e drilling cycle). 

The other questions you will get, do not depend on the controller you are using, as a job 
does not depend on a controller. Right from menu Help you will see several menus:  

 
In menu NC-jobs  there is big variety of NC-jobs available. This varies from drilling to 
pocketing and 4-axis programming. (pic.1)

 pic.1

In this example will now move step-by-step in generating an NC-program to machine a 
profile on the outside (Machine Outerprofile). 

Machine an Outerprofile 

Open drawing tennc01.ccd
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 pic.2

We will generate a program to machine this hexagon. 

Selection of controller 
First we will have to determine for which controller we want to generate the program. In this 
exercise we will choose Fan-alfa. This is the postprocessor for all common FANUC-controllers.
To insert an NC-window for Fan-alfa we move to menu: Special->Insert NC and select Fan-
alfa in the list of controllers. A second new window(NC-window) will appear in Tensor  (pic.3). 

 pic.3

In this window the NC-program will be written. Actually this window is a text-editor where the 
user can type or change text if so desired. 

Startlines
As any programs has its startlines we will define these first by moving to: NC-jobs->startlines
But before we do this, be sure that only the hexagon is selected. This is what you will see 
(pic.4): 

     pic.4

Enter the same values as shown in the pictures. Tensor will ask the user to determine the 
dimensions of the stockmaterial: cube or cylinder? In this case we will select the Cube-
shape(=1). 
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Now we need to define the position of the lower left- and upper right point of the cube in 
accordance with the drawing origin (0,0,0) (pic.5). This will eventually also be the origin of 
the NC-program. 
In this case we have selected the profile. Tensor will then automatically present values that 
surround the entire profile plus 10 percent. This will save you some time calculating. We can 
simply click on OK two times. 

  pic.5

If nothing had been selected Tensor will present default values of 100x100x20.

%
O1(TEST)
(FROM/50,50,100)
(STOCK/BLOCK,100,100,20,0,0,20)

In the NC-window you will see the startlines. Line 3 and 4 are between brackets. For FANUC-
controllers text between brackets will be skipped. But the lines are necessary for the Tensor 
NC-simulator to know what the startpoint of the tool and size of the stockmaterial will be. 

Job selection

1e

 pic.6

We will run through this dialog. Remember to use the same values as shown in the 
pictures. 

           pic.7

The topside of our cube will be our Z=0 plane. As we haven’t yet selected a tool for this job 
we will answer the question with yes (Y).
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Now the startlines are defined we will select from the list 
of NC-jobs. Deselect all elements in the Drawing window. 
Now select the hexagon as is shown in pic.6. We will 
choose direction climb-cut and the upper left line will be
 the first in selection. This means we are already now
 defining where the program will enter the profile and 
direction of cutting. Now move to menu NC-jobs->
Machine profile->Outerprofile. A dialog will start between 
user and Tensor which will result into a complete 
NC-program to machine the hexagon-profile.



Select from a toollibrary

 pic.8

When selecting a tool this dialogbox will appear(pic.8). You can see the user can select from a 
list of 8 different type of tools. Just to see what types of tools are available, click on each 
radio button and see what dimensions define each tool. In this exercise we will select a Flat 
End Mill. Values for the diameter height and angle can now be entered.  But there is also the 
option to select from a list of predefined tools. For this, click on button Get tool from DB 

pic.9

This is what you will see (pic.9). By clicking on Insert Tool the user can define new tools and 
add them to the list by clicking the Save button. (don’t forget to Save !). You can also delete 
tools from the list by clicking Delete Record 

Attention: Don’t forget to click on the Save-button when changes are being made ! 

Parameters of tools
The value Height stands for the cuttingheight of the tool. During simulation there will be a 
check if the depth is not too large. Tensor will return a warning if this is the case. (Just 
as there will be a collision check at Rapidfeed). Tool ID is the toolnumber which should be in 
accordance with the toolnumber defined on your CNC-controller, to prevent errors or collision 
on your machine. The Description of the tool will also appear in your NC-program to make it 
easier to check your program on the CNC-controller. Attention: some controllers only accept 
capital letters. For each tool you can define a separate Color for removed material during 
simulation. This will enhance the overview during simulation. 
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Select the SLOT MILL 10 from the list and click OK . Then again click on OK to confirm 
selection.  Finally click a third time on OK.
 
Tip: Drag the window when you are in the listing of tools(pic.8). You will then see the picture 
in the previous window(pic.9) explaining the parameters. 

Spindle speed and feedrate

     pic.10

By using the standard formules, spindle speed and feedrate will be calculated by Tensor. The 
calculated values can be changed by the user in the dialogbox after calculation if so desired. 
(pic.10)

Tooldata
As all tooldata are now defined, Tensor will present them to the user one more time:

 pic.11

In this dialogbox once again you can alter the cuttingconditions (pic.11)
 
NC-code to load tool
Tensor will now generate the necessary NC-code to load the tool. Each controller has its own 
specified NC-code for this. Thus each postprocessor will have different questions. For FANUC-
alfa the following dialogboxes appear:
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    pic.12
 
With this result:

G00 G28 G91 Z0
G49 Z0
M01
(TOOL/MILL,10,0,24,0)
(COLOR,255,128,0)
N2 (SLOTMILL 10)
G00 G17 G40 G49 G80 G90
T6 M6 
G54 G00 X10 Y10
G43 Z50 H6  S3819 M03

Again you will see lines between brackets. These are the values of the tool which the Tensor 
NC Simulator needs to simulate. Every time you load a tool the same dialogboxes appear. For 
instance you can also define and load a tool in menu Tool->Load Tool. 

Job parameters

 pic.13
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The user can now enter the values how the part should be machined. Number of steps will be 
adjusted to a higher value as 10/3=3,33. Later on you will be asked  if you want to finish the 
profile. 

You can enter a layername(description) for the toolpath (geometry) which will be 
generated.(pic.14) In this case we enter NC1. 

    
pic.14

An approach will be defined at the center of the first selected element in the chain. (pic.14) 
The value Tensor presents for the radius will be 60% of the diameter value, as a value 
smaller than 50% will probably generate an error on the controller for toolcompensation. To 
improve the surface in the profile at the position of the approach, you may enter an overlap 
value.
 
An extra line can be attached to the approach. This might come in useful if you don’t want the 
tool to plunge into the material but that  it will approach from outside the block. In this case 
we will enter No (N) (pic.15)

 pic.15

There are several ways to lower in Z. The most common is simply to plunge straight into the 
material. Tensor offers you two more options. They will be presented to the user. The first 
one is to lower in Z with a helix. The diameter of the helix and angle of plunging in Z is 
related to the diameter of the tool. In this case we will enter No(N).  (pic.16)

 pic.16

The second option is to plunge with a ramp. We will confirm with Yes(Y) and enter a value of 
15 degrees for the ramp. (pic.17)
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pic.17

NC-code for roughing 

 pic.18

NC-code is now being generated in the NC-window with the calculated values. You will also 
see Tensor generates comment at the beginning an end of a job: (END OF MACHINING 
OUTERPROFILE) and (START OF MACHINING OUTERPROFILE). This will help you in having a 
good overview of your program.

Click through your program using arrow-keys
By  using arrow-keys on your keyboard you can run through your NC-code in the NC-Window. 
At the same time you will see a red arrow in your drawing-window moving over the geometry 
which is in accordance with each NC-line. So if you want  to make any manual changes in 
your program (p.e. feedrate) you will know in which geometry of you part you are making 
changes. 

Profile finishing
As we entered an allowance of 1 mm, we want to finish the profile as well. We therefore will 
answer with yes(Y). First question is if you would like to load a new tool for finishing.(pic.19) 
In this case we will continue with the same tool and therefore enter No(N).

      pic.19

Automatically an approach is made. The user can define the step in Z for finishing the profile. 
Default the value will be the total depth which is most common in practice. We will leave the 
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value as it is (10 mm). Again NC-code is generated for finishing the profile, with the 
accompanied comment. 

Endlines
The NC-program is almost ready. To complete the program we will add endlines. For this we 
move to menu NC-jobs->Endlines. For FANUC-alfa the following lines will be added:

G00 G28 G91 Z0
G49 Z0
G28 Y0
M09
M30
%

Exercise: Try to make your own NC-program for an outerprofile. You can select 
a different CNC-controller. You will then see the code for loading a tool and 
start- and endlines differ from Fanuc. 

Save NC-program or send to machine with RS232 
You may make a copy of your program by moving to File->Save Copy as. Save the file as a 
text file. You can add a different extension the .tap (pic.20)

 pic.20

There is also the option to send the program directly to your machine by using the RS232-
option. (you will of course need a RS232-cable). Move to File->Send and you will see a 
dialogbox where you can define the parameters. Check the parameters on your controller, 
they should be he same (pic.21). By File->Receive you may send a program from your 
controller back to your PC and save it on your harddisk.

 pic.21
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Simulation

The Tensor NC mill Simulator
The program is now complete. To visualize and check if  no errors are made, we can simulate 
in Tensor NC Simulator. On the far right of you drawing-window there are eye-buttons. Move 
the mouse to the left eye-button. You will see a balloon with text SIMUL MILL:

By clicking on the left eye-button Tensor will make a copy on the harddsik of the content in 
the NC-window. We the can import this in the Tensor NC Simulator. 

If you did not start up the Tensor NC Simulator, you need to do this. If you followed 
instructions during installation you will have a shortcut on your desktop. If not read the these 
instructions at the beginning of this manual (Installation of Tensor). 
The best thing to do is always start the simulator when you start Tensor. You then only need 
to click on the bottom of your screen to switch between the two applications.

We now move to Tensor NC simulator. The first button on the left side of the toolbar is an 
eye-button. By clicking on this button Tensor NC Simulator will load the NC-program you just 
saved by clicking on the eye-button in Tensor. (The eye-buttons are made for the users 
comfort, to avoid the user first making a copy in Tensor by moving to menu File->Save copy 
as.. and afterwards move to menu File->Open .. ). If you just did a simulation Tensor NC 
Simulator will ask you to save a copy.  Answer with No, to avoid overwriting the copy you just 
made in Tensor. If you still want to have a copy again click the left eye-button in Tensor.

   pic.22

Immediately you will see a block representing the stockmaterial (pic.22). These are the 
dimensions we defined in the startlines. If there is no definition of stock in the NC-code, 
Tensor will notice and will ask you to enter values in accordance with the NC-program.
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Buttons

 pic.23

With these buttons(pic.23) we can choose how we want to run the simulation. The third 
button allows you to simulate the program step-by-step. The second button will give you a 
complete simulation until the end of the program. Clicking the fourth button will give you a 
time out. The fifth button will abort the simulation. You can then only start the simulation 
from the beginning. The first button(rarely used) will take you one step backwards each time 
you click. The removed material will not return but you will see a line or arc belonging to the 
NC-path. In this case click on the second button for an automatic run of simulation. The result 
will then be:

 pic.24

Try to run the simulation step-by-step using the third button. For this first click on the fifth 
button

Machiningtime 

  
The button with the measuretape allows you to check dimensions on the block after 
simulation. For example the distance between 2 parallel lines. 

But more interesting is the machiningtime. Click on the T-? V-? button to see what is being 
calculated. You may consider this quit accurate as time for toolchange is also included. 
pic.25): 
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 pic.25

External made programs
Programs not being made in Tensor can also be simulated in Tensor NC Simulator  

 pic.26

Attention: Be sure the program has the proper extension!!
If you p.e. want to simulate a Heidenhain program be sure to select the Filetype 
( extension) in this case Heidenhain TNC(*.h):So if necessary change the extension of 
the NC-program.

Probably tools present in the external program will not be defined for Tensor NC 
Simulator. But automatically at every tool command you will be able to define the 
dimensions and color of simulation. You can also move the cursor to a specific line and 
insert a tooldefinition by clicking the rightmousebutton. 

Conclusions
This was an example how to make a program for an outerprofile. What can we highlight here? 

Dialog 
First, there will be a dialog between the user and Tensor. Tensor will ask the questions and 
you answer by using your knowledge of machining, tools feedrates etc.  This means Tensor 
will do the unpleasant work (calculating) and you will always be in control.
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Startlines
In the startlines dimensions of the stock are defined which are later used in the Tensor NC 
Simulator. 

Load tool
When loading a tool the user can select form a tool library. The library can be changed and 
you can insert tools you use in your shop. Every tool can have its own color of simulation to 
improve the view while simulating. Code between brackets represent the tool dimensions and
 color. In the other NC-jobs in the NC-jobs menu loading a tool will be done in the exact same 
way as is shown in this example. But it can differ for different controllers. P.e. in Heidenhain 
you need to enter values for DL- and DR-, which you don’t have to do in Fanuc. Furthermore 
Tensor can calculate feedrates and spindle speed. If you do not select a new tool the last used 
tool will be the active tool. 

Cuttingconditions
Through dialogboxes with pictures the user will know what the parameters represent. You 
may decide to do a finishing using a different tool. After entering these values NC-code is 
automatically being generated in the NC-window. Where necessary you will see comment in 
your program. 

Simulation
After entering endlines the program can be simulated by clicking the left eye-button. Tensor 
will save the content of the NC-window which you can import into the Tensor NC Simulator by 
clicking the eye-button. Machiningtime is presented. 

Attention: At any given time you can do a simulation of generated NC-code, the program 
does not have to be completely ready. Let’s say you want to a drilling job after profiling. You 
can first simulate the profiling and then continue with a new job.
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Other NC-jobs 

We will briefly describe the other options in the NC-jobs menu and the other menus. 

Startlines
Startlines are being generated for each available postprocessor 

Endlines
Endlines are being generated for each available postprocessor 

NC simulation
This is the same function as the left eye-button.

Call subprogram
NC-code is being generated to call or define a subprogram. This is only activated for a few 
postprocessors (for example Acramatic).

End subprogram
NC-code to define end subprogram. This is only activated for a few postprocessors (for 
example Acramatic).

Facing surface
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 pic.27

By selecting a closed chain a clean surface-job is being generated. Tensor for example will ask 
the user to enter on which Z-level the job starts. This can be Z=5 with a depth of 5 mm which 
will result into surface on Z=0. Watch facing.avi 

Clean profile from block

 pic.28

You will frequently use this option. It allows you to machine a defined part from defined stock 
material. The stock material is defined by a closed chain you need to draw. Be sure the profile 
lies within the chain of stock material. 
ATTENTION!  
The profile of stock material must have a specified layername. This name should always(!) be 
# , so Tensor will be able to recognise this as stock material. Be sure that beside the 
elements of this profile no other elements have this layername # !!
The profile can be finished as well as the bottom with, if so desired, a different tool. When 
selecting the profile the user already determines the direction and order of finishing. Watch 
cleanprofile.avi

Machine inner/ outerprofile
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 pic.29

Inner and outerprofile are besides the approach direction exactly the same. It is possible to 
generate a finishing job with, if desired, a different tool. When selecting the chain the user 
defines direction and on which element the approach will be defined. Watch innerprofile.avi 

Clamp or microjoint
Tensor allows you to define positions(lines) in the profile to lift the tool if there are clamps 
holding the part. By changing these lines into dashed lines, Tensor will recognize these 
positions. Be sure to choose the correct linetype (type 2). Look at pic.30 .
  

 pic.30

 pic.31

Besides lifting the tool over a clamp Tensor offers you the option to leave a thin part of 
material. This by lifting the last cut in Z on the specified dashed lines. This might come in 
handy if there are no clamps to prevent the part being moved. For example you could leave 
0.5 mm of material and later after machining use a hammer to remove the part from stock 
material. Therefore we will call them microjoints. (pic.32)

microjoint

 pic.32
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Machine open profile

 pic.33

An open profile is treated a little bit different compared to a closed profile. There is an option 
to machine using toolcompensation while this is standard in a closed profile. Furthermore 
after each step the tool is being lifted to return to startposition and plunge. Watch 
openprofile.avi

Pocketing

          pic.34

Pocketing is an extended feature in Tensor. A number of profiles can automatically be 
pocketed. Each profile may contain islands, as long as they are completely situated within a 
outer profile. Each profile, island and bottom can be finished if so desired. It is possible to 
generate a drillingcycle at each startpoint of a toolpath, if so desired. 

ATTENTION! 
Be sure to take the following two remarks in account:
1. If you want to pocket with islands be sure that all island-profiles have the layername : $ 
Be sure that beside the elements of these profiles no other elements(!) have the layername $ 
2. The direction of the island-profiles should be opposite to the direction of the outerprofiles: 

When selecting the chains, the user defines direction and on which element approaches will 
be defined. This is always on the middle of the first element. Watch pocketing.avi

Conical closed profile
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 pic.35

This option allows you to machine and finish a conical surface. You can define several types of 
tools, like flatend mill and a bullend mill. After all, for a bullend mill the reference point will be 
on a different Z-level than a flatend mill when intersecting with conical surface. See pic.36

A AA

B B

 pic.36
 
In file conic.avi you may take a closer look at this option 

Exercise: Try do make a toolpath opening drawing conical profile.ccd

Convert toolpath to NC-code
If you have already defined a toolpath without using any options in the NC-jobs you can 
convert this into an NC-program by using this option. Tensor will ask you to define a tool and 
if you would like to use toolcompensation, and will then convert the toolpath directly into NC-
code. You can also use this option to convert a toolpath(geometry) generated by one of the 
options in the NC-job.  Watch convertpath.avi
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Convert 2D profile to 4-Axes on cylinder

 pic.37

This option allows you to wrap a 2D profile around a cylinder. Not only the diameter of 
cylinder needs to be defined but also the tooldiameter. If the exact profile needs to be 
wrapped, the toolpath needs to be corrected in a fourth axis. Tensor therefore will generate a 
4-axes program. To get an accurate result the profile needs to be divided into small lines. For 
this move to menu Change->Break->Interpolate. To get an accurate result don’t hesitate to 
enter small values: 

     

Watch profile4axes.avi.

Roughing 3D

 pic.38
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For more information about this feature read chapter 3D milling in Tensor. 

Machinecycles
In this feature you can use all cycles available in a controller. Most common used cycles are in 
ISO-controllers G81,G83 etc. For Heidenhain this may vary from CYCL 1, CYCL2 to CYCL 210 
etc. For this feature you need to select one or more points which represent the location on 
which the cycle is being executed. Watch cycle.avi.

Submenu Tensor cycli

In this submenu you may find several features you will probably often use. For example 
rectangular pocketing slotted hole or to engrave text on an arc.
 
Profile /cycles X-C
Here you can generate a multi-axes program for a multi-axis lathe-machine. This can be a 
profile. The program will not contain X and Y, but X and C-values. Also for cycles you will see 
XC coordinates. The C-value represents the angle of rotation for the Z-axis.
 
Menu Tool

This menu contains three items: 

Load Tool
With this option you can load a new tool at any required moment outside an NC-job. You will 
notice the same dialogboxes will appear as when you load a tool during an NC-job.
 
Show current tool
This allows you to check which tool is active on that particular moment. 

Calculate spindlespeed and feedrate
This option allows you to calculate a spindle speed and feed. Tensor will use the new 
calculated values. 

Menu Heidenhain
Most options available in the NC-jobs menu are to be found here as well. But in this menu 
Tensor will generate NC-code by using the LBL-function used in Heidenhain-controllers. This 
will shorten the NC-output and will give the user a better overview on the NC-program. There 
are some more options to manually generate specific Heidenhain-codes.

Menu Lathe
For this we refer to chapter NC-programming for lathe.

Menu Geometry

Geometry Data 
By selecting one or 2 elements Tensor will show data for these 2 elements. For example the 
distance between parallel lines or an angle between lines, distance between 2 arcs etc. The 
quickkey is D.

Check profile on small arcs
This feature will check if there are very small arcs present in a profile. If the length of these 
little arcs are smaller than 0.001 mm they are removed from the profile. The CNC-controller 
will see the start- and endpoint as an equal point. The chance is 50% the controller will 
generate a 360 degrees arc on you part. So that’s why the dangerous arcs are being 
removed.
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3D Milling in Tensor

Tensor is able to generate an NC-program for single- and doublecurved surfaces. These 
are being defined by cross- and longitudal sections. By working through several exercises 
in this chapter you will learn about features generating a 3D-program.
These features you may find in menu 3D.

Path and Skin

50

R10

 pic.1

Exercise: Draw and generate an NC-toolpath for cavity in pic.1

Define 3D geometry
By following the instructions you will construct the cavity as in pic.1:

1. Draw->Arc- >Coordinates and enter :

2. Repeat this but now enter -50 for the Z-coordinate. To be able to enter a Z-value 
you have to activate button 3D on in the dialogbox:
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3. Move to menu View->3D View and select ISO-view (quickkey Q):

      pic.2

4. We will now rotate the two arcs around the X-axis to get them in right position. If the 
two arcs are selected we move to Edit->Cut. With Edit->Paste the arcs are being pasted 
back into the drawing by entering 90 at Rotation X with this result:

 pic.3
5. Select the arcs in opposite directions, activate the Closed Chain-button and move to 
Draw->Line->Connect:

4



 pic.4
As mentioned you can imaginary define a surface between sections (skin). Then you will 
be able to generate a toolpath for this surface. In this example the lines are longitudal- 
sections and the arcs the cross-sections (vice-versa is also possible)

Generate 3D toolpath

In menu 3D you will find feature Set Path and Skin. Set Path defines the accuracy with 
which Tensor will approach the arcs. This because the toolpath will only contain (small) 
lines representing the arcs from the sections. If the longitudal sections also contain arcs 
(not in this example) they will be approached by lines. (pic.5). The deviation of the 
arc/lines is determined by three criteria: 
a) Max. length of division, 
b) minimum number of divisions and 
c) max error for arcs.

0.01

  pic.5

6. Select the two lines in direction and order as shown in pic.6.  

 pic.6
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7. Then move to menu 3D->Set Path and enter values shown in pic.7 and click OK. In 
this example Paths only contain lines. This means the last criterium does not apply in this 
case and therefore option b. is deciding

 pic.7

8. Deselect the lines. We will now select the cross-sections (skin) 
Attention: Be sure to select in the right order and direction. (see pic.8). The 1st skin 
starts where the first path starts and ends where the last path ends (in this case the 
second). The last skin (in this case the second) starts at the end of the first path and 
ends at the endpoint of the last path (in this case the second).

start 1st path

end 1st path

end 2nd path

start 2nd path

1st skin

2nd skin

 pic.8

9.
Now move to menu 3D->Skin.
In the dialogbox you can enter several parameters to determine the final toolpath:

Tool
You can define for what tool you want the toolpath to be generated.
In this case we select a bullend mill diameter 4. Leave the E-value 0. This means you 
enter a slotmill if the E-value equals the diameter value.

Accuracy
Here you will find option “Max. distance between lines”. The smaller the value the smaller 
the scallop-height on the end-result will be. We enter a value of 0.1 mm. Tensor will 
show approximately how many lines the toolpath will contain.

Connect
You can select a strategy. Zig-zag means the tool will then climb cut and then upper cut 
the surface. Select the Zig-zag option.

Toolpath
In this case the toolpath will be generated in direction of the two arcs as they are the 
skin sections. We prefer direction of the lines (Paths) and therefore select Perpendicular 
to sections.

Options
As we are machining a cavity we will activate Inward surface.

5-Axis
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By activating this option Tensor can generate 5-Axis simultaneous movements. We don’t 
need this now.

 pic.9

Enter values as shown in pic.9 and click OK. The result is the toolpath in pic.10. A detail 
of the toolpath is visible in pic.11:

  

Detail

    
pic.10 pic.11

Here Tensor generates one long toolpath containing 628 lines.

Exercise: Undo the Skin-action and try to enter different values to see what kind of  more 
strategies Tensor can offer you. 

Convert to NC-code
To convert the toolpath into NC-code, use feature Convert toolpath to NC-code in menu 
NC-jobs. 

You can watch this example in video 3D-a.avi. Drawing 3D-a.ccd contains the original 
sections geometry.
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Some more examples

 
pic.12 pic.13

Pic.12 and pic.13 are two more examples of 3D parts. For pic.12 you can open drawing 
3D-b.ccd and watch video 3D-b.avi. For pic.13 this is 3D-c.ccd and video 3D-c.avi. You 
can see that the number of sections is infinite. However, the paths must contain an equal 
number of elements. This doesn’t apply for the skin sections. And considering direction 
and order, remember the remarks made in 8.
Exercise: Try to make the toolpaths demonstrated in the videos, or define your own 3D- 
part.

3D Roughing

In Tensor you can define a roughing-job. As example we will take the part in pic.14 also 
to be found in drawing 3D-c.ccd.  First we will define a toolpath using Set Path and Skin. 
Only this time the toolpath will not be very accurate as we are merely roughing. This 
toolpath we will use as input for Roughing 3D. Open drawing 3D-c.ccd and select the four 
elements as you can see in pic14. These elements will be our 2 paths with the values in 
pic.15 .

pic.14
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 pic.15

We will now select the skin sections as in pic.16 and enter values as in pic.17:

 pic.16

 pic.17

We will use a slotmill 8 to rough this part. The result of this Skin-operation is the toolpath 
in pic.18:

4



 pic.18
This path is one chain. After selecting this chain we move to NC-jobs->Roughing 3D 
roughing and will define the complete roughing toolpath. There will be several 
parameters we need to define concerning stock material (pic.19) and depth of cut 
(pic.20). Enter Z-height 20 mm and step 5 mm .Also we need to enter values to plunge 
and retract form stock material (pic.21):

pic.19

 pic.20

 pic.21
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The output of this NC-job will be the toolpath in pic.22. Using Convert toolpath to NC-
code in menu NC-jobs you may convert this into NC-code. This is also demonstrated in 
3Droughing2.avi.

pic.22

Open a 3D –wireframe

 pic.23

Today, more and more you receive digital drawing of parts you need to make, like Dxf 
and Iges-files. These 2 formats you can import into Tensor.  A 3D model you will usually 
get in Iges-format. This will give you an advantage that Tensor directly converts the part 
1 on1 into a 3D-wireframe in the drawing-window, from which you may define paths and 
skins. (pic.23) 

Exercise: open file Iges.igs in Tensor

Activate the Default 3D-view in menu View->3D View (quickkey Q). We will use the Path 
and Skin features to get a quick result. Select the two chains as shown in pic.24. (first 
select the upper chain) so the toolpath will start from the top. 
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2

1

 pic.24

Now define the paths in  menu 3D->Set Path. By entering 0 and 1 for the first two 
parameters we will limit the number of lines in the toolpath as for one line from the path 
we only need one NC-line. The deciding criterium here will be the accuracy of the fillets. 
(pic.25)

 pic.25

Now select the lines connecting the two paths in order and direction as in pic.26 . 

 pic.26

Now move to menu 3D->Skin and enter the values form pic.27: 
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  pic.27

The tool will lower 2 mm per layer and the result will be a zig-zag toolpath along the 
surface of this part. (pic.28)

 pic.28

You can also watch video Iges.avi.
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Extrude

direction extrusion

Extrusie profile

 pic.29

In  this  example  we  will  project  the  spiral  on  a  single  curved  surface.  By  imaginary 
extruding the profile in Y-direction we will define the surface, on which the spiral will be 
projected.

Exercise: Open drawing extrude-y.ccd 
Select the profile an move to menu 3D->Set Surface->Extrude Y. (pic.30)

 pic.30

Tensor will now save the imaginary surface in its memory by extruding the profile in Y-
direction. The profile will automatically be deselected.
Now we select the spiral using the left-mousebutton and the  SHIFT-key and move to 
feature Projection in menu 3D:
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 pic.31

The dialogbox from pic.31 will  appear.  Several  parameters  can be defined.  First  the 
accuracy of projecting on the surface. We set this to 0.01 mm. The generated toolpath 
depends on what tool we will use. A ballmill will intersect the surface on a different point 
than a slotmill will do. Tensor will calculate this for you. This means if you enter a value 
0, the result will be a toolpath that exactly lies on the extrude surface as no correction is 
required with tooldiamer 0. We will define a ballmill of 8 mm.

Option Project tor -Z we will not activate in this case. This means we will get a toolpath 
where Tensor presumes the tool starts from above the surface. If we activate this option 
it’s presumed the tool will approach from below the defined surface. The result you can 
see in pic.32.

pic.32

The path contains small lines. To imagine how the result will be look at the Front View 
(pic.33). 

 pic.33

You can also watch video extrude-y.avi.
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Rotate Z

rotate-Axis

rotate profile

  pic.34

By rotating the profile 360 degrees around the Z-axis (rotate-axis) Tensor will create an 
imaginary surface. (see pic.34)

Exercise: Open drawing rotz.ccd 
Select the profile as in pic.34. This profile lies in the XY-plane/ To rotate it around the Z-
axis we need to rotate it first 90 degrees over the X-axis so it will lie in the XZ-plane. 
Move to menu Edit->Cut and then  Edit->Paste this by entering 90 degrees in Rotate X 
(pic.35).

 pic.35

The profile now is in the right position to the Z-axis. Keep the profile selected and move 
to  menu  3D->Set  Surface->Rotate  Z.  Tensor  will  now define  the  imaginary  surface. 
Deselect the profile.

In this drawing there is  a spiral,  but  it  is  not visible right  now because it  has been 
blanked. We can unblank this through menu Edit->Unblank and select for Layer spiral.  If 
the spiral is not completely visible in the window use  View->View all.  Keep the spiral 
selected and move to menu 3D->Projection. We will enter the same values as we did for 
the Extruding-example (ballmill diameter8 and accuracy 0.01). The result is to be seen 
pic.36 .

You also take a look at rot-z.avi.
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 pic.36

The front view will give you a better picture to understand what this feature does 
(pic.37)

pic.37

Interpolate
Here you can project geometry on a double curved surface. To define this surface use the 
Path and Skin features. Define a path and when selecting the skin-sections instead of 
moving to 3D->Skin you move to 3D->Set Surface->Interpolate. 
Attention: Remember the path need to have an equal number of elements.

Take a look at interpol.avi to see how this Works.

P.e you could project a text on a surface while machining a cavity for a plastic-mould. Try 
to do this using the Projection feature.

Summary
You have learned how to create toolpaths for 3D shapes. You will also notice there are 
limitations to the capacity in generating 3D-toolpaths. High-end solutions will provide you 
better and stronger solutions. If for example you would like to fillet two double curved 
surfaces you will not manage this using Tensor. But what you did see is that 90% of 3D-
parts you will run into can be programmed with Tensor. 
What are the main points which we will point out in this summary concerning 3D-
programming. 

1. Defining 3D geometry. Try as much as possible to draw you geometry in 2D (XY-
plane) and afterwards move or rotate this in the right position in 3D using the 
clipboard (Cut->Paste) .

2. Try to define logical paths and skins when defining a 3D part. Remember the 
paths and skins need to intersect and be divided at the intersection point (Edit-
>Break->Intersect). If not, the skin–feature will turn grey in the menu and will 
not work.

3. Select  paths en skins in the right direction and order. The startpoint of the 1st 

skin is also the startpoint of the 1st path. The endpoint of the last skin is also the 
endpoint of the last path.

4. Try to get a 3D-wireframe from your customer if possible in Iges-format(version 
3.5). It might save you a lot of time. Specifically ask your customer to save the 
3D model in his CAD-sytem as wireframe-model!! This will avoid that there will be 
a lot of unnecessary geometry in the Iges-file which you then have to remove 
yourself.

5. The more you practice the better you will get in constructing 3D parts. It requires 
more imagination to work in 3D than it does in 2D.
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NC-programming for lathe 

In chapter Drawing with Tensor we learned how to define geometry. In this chapter we 
will work through an example how to generate code for lathe-jobs. 

Right from menu Help you will see several menus:  

 
In menu Lathe there is a big variety of lathe-jobs available. This varies from roughing 
cycles to drillcycles. (zie pic.1)

 pic.1

In this example will now move step-by-step in generating an NC-program to machine a 
profile with a roughing-cycle and a drill cycle. 

To generate a lathe program we first need to define the profile we want to machine:
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 pic.2

Drawing the profile
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You can do this in the way you learned in chapter Drawing with Tensor. However, in 
menu Lathe you will find feature Define profile/ convert to NC. Here you can define your 
lathe profile step-by-step through dialog. 
Watch lathe1.avi 

In lathe1.avi you will see how easy you may define the profile in pic.2 
If you define this without the above mentioned feature, remember lathe is usually 
programmed in a different plane than XY, namely the ZX-plane. Therefore you will have 
to change this manually. You can do this by moving to menu Special->Options tab-page 
Coordinates. Here you can also activate diameter programming instead of radius 
programming by activating Y=Y*2.  (pic.3). At the startpoint we will define a line of 10 
mm.
Try to make the profile using Define profile feature or open drawing lathe1.ccd.

 pic.3

Selecting controller 
First we have to decide for which controller we want to make the NC-program. In this 
example we will select Fanuc 0T, the most common used controller, We move to Special-
>Insert NC and select the Fanuc 0T form the list (pic.4):

 pic.4

A new window will appear in Tensor: the NC-window. In this window the NC-program will be 
written. Actually this window is a text-editor wherein the user can type or change text if so 
desired. 

Startlines
As any programs has its startlines we will define these first by moving to: Lathe ->Startlines: 
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pic.5

In this chapter we will enter the same values as are shown in the pictures. Tensor will then 
ask the user to determine the dimensions of the stock material. If the profile is selected 
before you activate Startlines Tensor will present dimensions surrounding the profile. If not 
you will have to calculate the values. Therefore it’s preferred to select the profile. 

In Startlines automatically you will be asked to load a tool. That’s why Tensor will ask how 
retract to a safe position. (pic.6):

  pic.6

%
O1000
(STOCK/110,130,0,-1)
G28 U0
G28 W0

In the NC-window the first NC-lines appear with the definition of the stockmaterial in line 2. 
This is between brackets as the Fanuc-controller will consider this as comment. However the 
Tensor NC Simulator will use these to simulate the program.
 
We will now load a lathe-tool(=0). It is also possible to load tools for driven tools (=1) (pic.7), 
but more about this later on. We will now concentrate on lathe-jobs.

 pic.7

Select from toollibrary

 pic.8
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A window of a tool library will pop u on your screen (pic.8). There are 5 possible types of tool 
to be defined/selected. By clicking on a every one of the radio-buttons you will see what type 
and what parameters define the tools. In this case we select Standard tool. Values like 
tooltipradius etc. can now be entered. However, it is also possible to select from a database. 
Click on button “Get tool from DB ”. 

The following window appears (pic.9): 

pic.9

This is what you will see (pic.9). By clicking on Insert Tool the user can define new tools and 
add them to the list after clicking Save button. (Don’t forget to Save!). You can also delete 
tools from the list by clicking Delete Record 

Attention: Don’t forget to click on the Save-button when changes are being made ! 

Parameters of tools
The description of the tool will also appear in your NC-program to make it easier to check 
your program on the CNC-controller. Attention: some controllers only accept capital letters.
Tool ID is the toolnumber which should be in accordance with the toolnumber defined on your 
CNC-controller, to prevent errors or collision on your machine. For each tool you can define a 
separate color for removed material during simulation. This will enhance the overview during 
simulation.

Tip: Drag the window when you are in the listing of tools(pic.9). You will then see the picture 
in the previous window(pic.8) explaining the parameters. 

Select  de EXT. STANDARD 1 with ID 0101 and click on OK. You can also enter values for 
spindle speed and feedrate.

Then click OK twice. The result in the NC-window will be:

(TOOL/STANDARD,30,55,0.2,12,3)
(COLOR,0,255,128)
T0101
G96 S3500
G50 S150 F0.2 M3

The program now contains the necessary code to load a tool on your machine. Dimensions of 
the tool and color of simulation is described between brackets. 

Roughing cycle

We will now select the profile (direction or chain should be in –Z).
On practically every CNC-controller an axial roughing cycle is available. For Fanuc this is 
cycle G71. In menu Lathe this feature is also present Axial Roughing (G71) and we will 
therefore select the feature. 
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 pic.10

In pic.10 you can see there is a picture describing the parameters you are asked to enter 
for the axial roughingcycle. Most values speak for themselves. Except the first parameter 
needs some more explanation. For this moment we will enter value 0 (According G). 
Later on this chapter we will highlight this. By clicking OK you will be asked to enter the 
number for the start- and endline of the profile. (pic.11). We enter 10 and 20. For 
toolcompensation we select right(=2) compensation.

  pic.11

The NC-code for the G71-cycle is now written into the NC-window. Automatically Tensor 
proposes to finish the profile with G70. Usually this is preferred (pic.12) 

  pic.12

As it concerns the same profile we enter 10 and 20. The total result is shown below: 

G71 U2. R2.
G71 P10 Q20 U0.2 W0.3 F0.2
N10 G0 G00 X0.
G42 G01 Z0. 
G01 X70.
G01 X80. Z-5.
G01 Z-45.858
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G02 X85.858 Z-52.929 R10.
G01 X114.142 Z-67.071
G03 X120. Z-74.142 R10.
N20  G40 G01 Z-100.
G70 P10 Q20

Drilling 

To drill a hole of 10 mm we will use the available drillcycle on the controller. As the depth 
of drilling will is 40 we will choose Deepdrill cycle G83. First we need a toolchange to load 
a drill diameter 10. Move to menu Lathe->Load tool. The procedure is the same  as we 
already have seen in the Startlines. Only this time we will select from tooltype Drill.
Click on “Get tool from DB ” to select from the list (pic.13):

 pic.13

(TOOL/DRILL,10,120,60)
(COLOR,255,255,0)
T0505
G97 S1500
G50 S160 F150. M3

The NC-code to load the drill is generated in the NC-window. Now activate Deepdrill cycle 
G83 in menu Lathe and enter these values (pic.14):

  

 pic.14

G0 X0 M8
Z2.
G83 Z-40. R2. Q6000 F150.
G00 G80 X200. Z150. T0500M09

Endlines

To finish the program we will make the endlines in Lathe->Endlines.
G0Z50.
G49 Z0
M05
G00G91G28X0Y0Z0
M30
%
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In video lathe2.avi you can watch the actions described in this example. 
Exercise: Try to make a NC-program for this profile entering different values. 

Simulation

The Tensor NC lathesimulator.
The program is now complete. To visualize and check if  no errors are made we can simulate 
our program in Tensor NC Simulator. On the far upperright of your drawing-window there are 
eye-buttons. Move the mouse to the right eye-button. You will see a balloon with text SIMUL 
LATHE

 pic.15

By clicking on the right eye-button Tensor will make a copy on the harddisk of the content in 
the NC-window. We the can import this in the Tensor NC Simulator. 

If you did not startup the Tensor NC Lathe Simulator, you need to do this. If you followed 
instruction during installation you will have a shortcut on your desktop. If not read the these 
instructions at the beginning of this manual (Installation of Tensor). The best thing to do is to 
start the simulator when you start Tensor. You simply need to click on the bottom of your 
screen to switch between the two applications.

We now move to the Tensor NC simulator. The first button on the left side of the toolbar is an 
eye-button. By clicking on this button Tensor NC Simulator will load the NC-program you just 
saved by clicking on the eye-button in Tensor. The eye-buttons are made for the users 
comfort, to avoid the user first making a copy in Tensor by moving to menu File->Save copy 
as.. and afterwards move to menu File->Open ..  in the simulator. 

 pic.16

Attention: If you just made a simulation Tensor NC Simulator will ask you to save a copy. 
Answer with No, to avoid overwriting the copy you just made in Tensor. If you still want to 
have a copy again click the right eye-button in Tensor.

 pic.17
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When the file is opened Tensor NC Simulator will recognize the lines describing the 
stockmaterial and will present it. Also the geometry of tools is known so we can start 
simulation. There are several ways to run a simulation: step-by-step or automatically. 

Buttons

 pic.18

With these buttons(pic.18) we can choose how we want to run the simulation. The third 
button allows you to simulate the program step-by-step. The second button will give you a 
complete simulation until the end of the program. Clicking the fourth button will give you a 
time out. The fifth button will abort the simulation. You can then only start the simulation 
from the beginning. The first button(rarely used) will take you one step backwards each time 
you click. The removed material will not return but you will see a line or arc belonging to the 
NC-path. In this case click on the second button for an automatic run of simulation. The result 
will then be:

Try to run an automatic simulation by clicking the 2nd button. First the G71 cycle will be 
simulated where after the hole will be drilled (G83). (pic.19)

 pic.19

Machiningtime 

  
The button with the measuretape allows you to check dimensions on the block after 
simulation. For example the distance between 2 parallel lines or dimensions of diameters. 

But more interesting is the machiningtime. Click on the T-? V-? button. The result (pic.20): 
 

 pic.20
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 fig21

By clicking the rightmousebutton in the 3D-window you can select a crossection view of 
your part. (pic.21)

Watch lathe3.avi to see what is described above.

Compensated toolpath

Sometimes you bump into the problem you want to machine a part without using 
toolcompensation calculated by the controller (G41,G42). The toolpath you then need to 
define, is different when using G41 or G42. In menu Lathe you can use feature Conversion to 
profile without compensation to solve this problem. It will save you a lot of time calculating 
the path. After selecting the profile two parameters need to be defined. These are the 
tooltipradius and the location of the referencepoint (there are 9 possible locations). See pic.22

 pic.22

Tensor will then calculate the path the referencepoint needs to follow to give you a correct 
result on your machine. See pic.23
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pic.23

You can do this both for an inner- as outerprofile.
To convert this compensated path into NC-code move to menu Lathe-> Define profile/ 
convert to NC.
Watch video corrected.avi. 
Attention: Take in account the tool is always located on the right side of the profile

Other cycles
In menu Lathe you will find a number of lathe-jobs to be used like radial roughing,
 canned cycle, threading and drillcycles. In feature Define profile/ convert to NC
you can convert a profile directly into NC-code (G01,G02 en G03).

Tensorcycle
For the first parameter in the G71-dialogbox (pic.10) we entered a value of 0. If we 
however had entered a value of 1 the G71 and G70 would have been replaced with 
Tensor70 and Tensor71. If you then open this program in the Tensor simulator you will 
notice the program is substantial greater. This because Tensor70 and Tensor71 will be 
totally written out in G00, G01, G02 and G03 in X- Z-coordinates. This means you have a 
NC- controller independent NC-program. Therefore it can be used for different 
controllers. Especially for controllers that don’t have intelligent cycles such as G71, G72, 
G73, G81 etc. 

External made programs
Programs not being made in Tensor can also be simulated in Tensor NC Simulator 
Attention: Be sure the program has the proper extension!!
If you p.e. want to simulate a Fanuc10T program be sure to select the Filetype 
(extension) in this case Fanuc10TA(*.nc1). So if necessary, change the extension of the 
NC-program. (pic.26)

 pic.26
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Probably tools present in the program will not be defined for Tensor NC Simulator. But 
automatically at every toolcommand you will be able to define the dimensions and color 
of simulation. You can also move the cursor to a specific line and insert a tooldefinition 
by clicking the rightmousebutton. 

Conclusions
This was an example how to program an axial roughing cycle and to drill a hole. What can we 
highlight here? 

Dialog 
First, there will be a dialog between the user and Tensor. Tensor will ask the questions and 
you answer by using your knowledge of lathe.  This means Tensor will do the unpleasant work 
(calculating) and you will always be in control.
 
Startlines
In the startlines dimensions of the stock is defined which is later used in the Tensor NC 
Simulator.

Load tool
When loading a tool the user can select form a toollibrary. The library can be changed and 
you can insert tools you use in your shop. There are 5 different types of lathe tools. Every tool 
can have its own color of simulation to improve the view while simulating. Code between 
brackets represent the tool dimensions and color. If you want to add a lathe-job to your 
program using a new tool move to Lathe->Load tool first, as this is not being done when 
defining an new job. If not, the last tool will be used.

Cuttingconditions
Through dialogboxes with pictures the user will now what the parameters represent. You may 
decide to do a finishing using a different tool. After entering these values NC-code is 
automatically being generated in the NC-window. Where necessary you will see comment in 
your program. 

Simulation
After entering endlines the program can be simulated by clicking the left right-button. Tensor 
will save the content of the NC-window which you can import into the Tensor NC Simulator by 
clicking the eye-button. Machiningtime is presented. 

Attention: At any given time you can do a simulation of generated NC-code, the program 
does not have to be completely ready. Let’s say you want to a drilling job after profiling. You 
can first simulate the profiling and then continue with a new job.
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Tips and tricks

In this chapter we will give you a number of tips and tricks you can use when working in 
Tensor. It will help you to get a better benefit when programming.

Direct NC-code
If you only need to convert geometry into plain NC-code (G01,G02,G02 or L,CC,RND)
Do the following: move to menu Special-> Insert NC and select desired controller. Move back 
to the drawing-window and select the geometry you want to convert. In menu Special you 
can see option Generate NC. Click on the item and you will see the NC-code appear in your 
NC-window. If not, check if the right item in menu Contour in the NC-window is activated. 
One of the first three should activated. You can also click on the camera-button you will see in 
the toolbar of the NC-window.
 
Scaling
If you want scale geometry this is done very easy by using the clipboard. Select the geometry 
and copy this to the clipboard Edit->Cut(or Copy) Then paste this back into the drawing Edit-
>Paste. First click on the Reset-button so all values are rest. Then enter 2 for the scale 
parameter if you want to double the size of the geometry.
 

 pic.1

Offset a profile
To define an offset to a profile move to Draw-Other curves->Offset:

 

2

    pic.2

Imorting a DXF-file
Probably you frequently will be offered a DXF-file instead of a paper drawing. Tensor can 
import this without any problem. Often the file contains too much geometry you don’t 
need to machine the part. The best thing the to do is to open a new drawing: menu File
->New->Drawing (Normal). Then move to menu Window->Tile Vertical (quickkey CTRL-
T)  so both windows are visible. Now select the geometry you want to use in the DXF-
window. Copy this to the clipboard (Edit-> Copy) then move to the new window you 
inserted, and paste the geometry (Edit->Paste) in the drawing by clicking the Reset- 
button in the Paste-dialogbox first. You can now close the Dxf-file and continue. 
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The geometry however will not be on the desired position in X-Y coordinates. How to 
Watch video ten06.avi to look at the best way to do this. This is also described on 
page19 of this manual.

Draw a cube in seconds
Take look at cube.avi to see a demonstration of how work creative with Tensor

Important when using the clipboard
If you are pasting geometry in the drawing, try to learn yourself always first press the 
Reset-button before you start entering values. You might overlook some parameters that 
are not zero. 
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http://ten0.avi/


Exercises

In this chapter you will find 15 drawing. You can also find them in the directory where 
you unzipped OnyourwaywithTensor zip.exe. As you are drawing you can play the 
accompanied video Windows Media-player.
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Exercise 1
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Used options:

 Draw->Line->Aligned (fastkey L)

 Draw->Arc->Fillet (fastkey F)

 Edit->Trim+extend->Chain (fastkey T)

 Special-> Close (closed profile)
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Exercise 2
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Used options:

 Draw->Arc->Coordinates (fastkey C)

 Draw->Line->Aligned (fastkey L)

 Edit->Trim+extend->Chain (fastkey T)

 Draw->Arc->Fillet (fastkey F)

 Special-> Close (closed profile)
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Exercise 3
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 Draw->Arc->Coordinates (fastkey C)

 Draw->Line->Aligned (fastkey L)

 Draw->Arc->Fillet (fastkey F)

 Edit->Copy (fastkey Ctrl-C)

 Edit->Paste (fastkey Ctrl-V)
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Exercise 4
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 Draw->Line->Aligned (fastkey L)

 Draw->Line->Angle

 Draw->Arc->Fillet (fastkey F)

 Special-> Close (closed profile)
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900

170o

120 o

45
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7

A line pointing to the right is 
absolute 0 degrees . Vertical 
up is 90°, to the left is 180°, 
and  downwards is either 270° 
of -90°.



Exercise 5
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 Draw->Arc->Coordinates (fastkey C)

 Draw->Line->Angle

 Draw->Arc->Fillet (fastkey F)

 Edit->Copy (fastkey Ctrl-C)

 Edit->Paste (fastkey Ctrl-V)

 Edit->Trim+extend->Chain (fastkey T)

 Special-> Close (closed profile)
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Exercise 6
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 Draw->Line->Aligned (fastkey L)

 Draw->Line->Angle

 Draw->Arc->Fillet (fastkey F)

 Draw->Arc->Coordinates (fastkey C)

 Edit->Trim+extend->Chain (fastkey T)

 Special-> Close (closed profile)
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Exercise 7
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 Draw->Line->Aligned (fastkey L)

 Draw->Arc->Fillet (fastkey F)

 Draw->Line->Angle

 Draw->Punt->On entity

 Draw->Arc->3 Elements (fastkey 3)

 Edit->Trim+extend->Chain (fastkey T)

7



Exercise 8
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 Draw->Line->Aligned (fastkey L)

 Draw->Arc->Fillet (fastkey F)

 Draw->Line->Angle

  Axis->Snap to (fastkey P)

 Edit->Trim+extend->Tot Chain

 Axis->Reset (fastkey R)

 Draw->Line->Join

 Edit->Trim+extend->Chain (fastkey T)

 Special-> Close (closed profile)

By temporary displacing the axes a simple solution can be found to define 
the line on the upper right. Afterwards, don’t forget to Reset the axes in 
the original position.
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Exercise 9
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 Draw->Arc->Coordinates (fastkey C)

 Draw->Line->Aligned (fastkey L)

 Draw->Arc->Fillet (fastkey F)

 Draw->Punt->Coordinates 

 Draw->Line-> Tangent

 Special-> Close (closed profile)
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Exercise 10
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 Draw->Arc->Coordinates (fastkey C)

 Draw->Line->Aligned (fastkey L)

 Draw->Arc->Fillet (fastkey F)

 Edit->Trim+extend->Chain (fastkey T)

 Draw->Line-> Tangent

 Special-> Close (closed profile)
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Exercise 11
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 Draw->Line->Aligned (fastkey L)

 Draw->Line->Angle

 Draw->Line ->Chamfer

 Edit->Trim+extend->Chain (fastkey T)

 Edit->Copy (fastkey Ctrl-C)

 Edit->Paste (fastkey Ctrl-V)

 Edit->Reorganize->Reduce and optimize

8



Exercise 12
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 Draw->Arc->Coordinates (fastkey C)

 Draw->Arc->Fillet (fastkey F)

 Edit->Trim+extend->Chain (fastkey T)

 Draw->Line->Aligned (fastkey L)

 Special-> Close (closed profile)
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Exercise 13
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 Draw->Line->Aligned (fastkey L)

 Draw->Arc->Coordinates (fastkey C)

 Draw->Line-> Tangent

 Edit->Copy (fastkey Ctrl-C)

 Edit->Paste (fastkey Ctrl-V)

 Draw->Arc->Fillet (fastkey F)

 Special-> Close (closed profile)

 Edit->Reorganize->Reduce and optimize
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Exercise 14
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 Draw->Arc->Coordinates (fastkey C)

 Draw->Line-> Tangent

 Draw->Line->Aligned (fastkey L)

 Edit->Copy (fastkey Ctrl-C)

 Edit->Paste (fastkey Ctrl-V)

 Draw->Arc->Fillet (fastkey F)

  Axis->Snap to (fastkey P)

 Draw->Line->Angle

 Axis->Reset (fastkey R)

 Edit->Trim+extend->Chain (fastkey T)

 Edit->Modify Mode

 Special-> Close (closed profile)

 Edit->Reorganize->Reduce and optimize
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Exercise 15
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 Draw->Arc->Coordinates (fastkey C)

 Draw->Line->Aligned (fastkey L)

 Draw->Arc->Fillet (fastkey F)

 Edit->Trim+extend->Chain (fastkey T)

  Axis->Verplaatsen

 Axis->Roteren

 Draw->Line->Angle

  Axis->Snap to (fastkey P)

 Special->Close (closed profile)

  Axis->Reset (fastkey R)

 Edit->Reorganize->Reduce and optimize
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